Npm install error

Halo saya mau bertanya kenapa setiap saya install apapun yang awalnya npm selalu ada warning seperti ini
npm WARN @angular/animations@8.2.2 requires a peer of @angular/core@8.2.2 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/cdk@8.1.2 requires a peer of @angular/core@^8.0.0 || ^9.0.0-0 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/cdk@8.1.2 requires a peer of @angular/common@^8.0.0 || ^9.0.0-0 but none is installed. You must install
peer dependencies yourself.
npm WARN @angular/common@7.2.15 requires a peer of @angular/core@7.2.15 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/forms@7.2.15 requires a peer of @angular/core@7.2.15 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/http@7.2.15 requires a peer of @angular/core@7.2.15 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/material@8.1.2 requires a peer of @angular/core@^8.0.0 || ^9.0.0-0 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/material@8.1.2 requires a peer of @angular/common@^8.0.0 || ^9.0.0-0 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/material@8.1.2 requires a peer of @angular/forms@^8.0.0 || ^9.0.0-0 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/platform-browser@7.2.15 requires a peer of @angular/core@7.2.15 but none is installed. You must install
peer dependencies yourself.
npm WARN @angular/platform-browser-dynamic@7.2.15 requires a peer of @angular/core@7.2.15 but none is installed. You must
install peer dependencies yourself.
npm WARN @angular/router@7.2.15 requires a peer of @angular/core@7.2.15 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic/angular@4.6.0 requires a peer of @angular/core@^7.2.1 but none is installed. You must install peer dependencies yourself.
npm WARN ng-circle-progress@1.0.0 requires a peer of rxjs@^5.1.0 but none is installed. You must install peer dependencies yourself.

audited 55072 packages in 8.525s
found 34 high severity vulnerabilities
  run `npm audit fix` to fix them, or `npm audit` for details
avatar ShinMi

Ditanyakan oleh @ShinMi

8 Kontribusi 1 Poin

Login untuk menanggapi


Jawaban

melihat jawaban dari stackoverflow masalah menginstall npm di angular , kamu perlu mengupdate versi angularnya di package.json lalu jalankan "npm install" lagi. Versinya sesuiakn degnan yang disarankan di atas
avatar hilmanski

Dijawab oleh @hilmanski

2164 Kontribusi 1748 Poin

Login untuk menanggapi


avatar Hanifnahara

Dijawab oleh @Hanifnahara

1 Kontribusi 0 Poin

Login untuk menanggapi


Login untuk gabung berdiskusi